MTD ITSA: Scheduled Maintenance on Sunday 6th April from 12am to 12pm on Tuesday 15th April

Scheduled for Apr 11, 17:00 BST  -  Apr 15, 12:00 BST

Update

Due to scheduled maintenance for MTD ITSA, you will be unable to access our online service from:

5pm on Friday 11th April to 12pm on Tuesday 15th April

In addition, from 00:01am on Sunday 6 April 2025 to midday Tuesday 15 April 2025 submissions through software for Making Tax Digital for Income Tax will be unavailable for:

- any updates for the 2025 to 2026 tax year (6 April 2025 to 5 April 2026)
- finalisations of customers’ income tax position and submission of tax return for the 2024 to 2025 tax year (6 April 2024 to 5 April 2025)

We apologise for any inconvenience this may cause.

This and other planned maintenance and upgrade activities are shown on HMRC's service availability and issues page on GOV.UK: https://www.gov.uk/government/collections/hm-revenue-and-customs-service-availability-and-issues
Posted Mar 21, 2025 - 09:41 GMT

Scheduled

Due to scheduled maintenance for MTD ITSA, you will be unable to access our online service from:

5pm on Friday 11th April to 12pm on Tuesday 15th April

We apologise for any inconvenience this may cause.

This and other planned maintenance and upgrade activities are shown on HMRC's service availability and issues page on GOV.UK: https://www.gov.uk/government/collections/hm-revenue-and-customs-service-availability-and-issues
Posted Mar 13, 2025 - 10:17 GMT
This scheduled maintenance affects: Production environment.